Plesk impossibile aggiornare i servizi

Oggi vorrei parlare di un problema che ho avuto sulla mia VPS mentre cercavo di fare l’upgrade della mia versione php e MySql.

Bene il problema si è presentato quando da Plesk, sotto la voce Strumenti e Impostazioni -> Plesk -> Aggiornamenti, appariva la seguente scritta in rosso:

Failed to read product information from the file : Can't process products.inf3: Failed to download the package http://20141021-09h35m01s.parallels.mirrors.ovh.net.snapmirror.vps.ovh.net/parallels/products.inf3:
The requested URL returned error: 404
Can't process versions.inf3: Failed to download the package http://20141021-09h35m01s.parallels.mirrors.ovh.net.snapmirror.vps.ovh.net/parallels/versions.inf3:The requested URL returned error: 404

Questo non mi permetteva ne di aggiornare la versione di Plesk ne tantomeno di installare nuovi componenti.
Così girando sul web tra forum vari ho capito che il problema non era dovuto a Plesk ma bensì alla mia macchina linux servita dal mio Hosting Provider e molte altre persone con il mio stesso hosting avevano avuto il problema prima di me, per intenderci si parla di OVH un hosting francese.

Cambiare la directory degli aggiornamenti Plesk

A questo punto ho deciso di contattare il supporto del mio hosting, nonostante io non abbia un servizio managed, loro mi hanno consigliato di leggere un thread sul proprio forum dove si parlava del suddetto problema ed in cui era stata trovata la soluzione grazie al seguente comando:

find /root -type f -name .autoinstallerrc -exec sed -i "s,http://[0-9hms-]*\.\([^/]*\).snapmirror.vps.ovh.net,http://\1,g" "{}" ';'

Il comando va eseguito tramite terminale con l’utenza di root, ovvero che ha i super permessi di accedere a tutte le cartelle del server e permette di cambiare la directory dalla quale Plesk attinge per scaricare gli aggiornamenti.

Una volta eseguito il comando in questione ho fatto un riavvio della macchina e tornando poi nella pagina degli aggiornamenti finalmente il messaggio di errore era sparito ed ho potuto finalmente aggiornare la versione del mio Plesk, installare i nuovi componenti php ed anche il supporto ad una nuova versione di MySql dopo aver installato il modulo Atomic da terminale.

Ora vi saluto con la speranza di essere stato il più chiaro possibile, non esitate a contattarmi per qualsiasi dubbio o informazione tramite i commenti a fondo pagina o l’apposito modulo di contatto nella pagina Get in Touch! 🙂